Quest Data Protection Service Disruption
Incident Report for Quest Data Protection
Resolved
A fix has been implemented.
We'll keep monitoring the service status.
Posted Apr 08, 2019 - 05:20 EDT
Identified
We are currently experiencing a service disruption.
Our engineering team has identified the root cause and implementing a fix.
Posted Apr 07, 2019 - 05:37 EDT
Investigating
We are currently experiencing a service disruption.
Our engineering team is working to identify the root cause and implement a solution.
Posted Apr 07, 2019 - 03:16 EDT
This incident affected: Data Protection Portal (Web User Interface).