Pages may be slow loading
Incident Report for Quest Data Protection
Resolved
This incident has been resolved.
Posted Jan 23, 2019 - 17:53 EST
Identified
The Data Protection portal is currently experiencing a higher than normal volume of activity, which may be causing pages to be slow or unresponsive.
We're investigating the cause and will provide an update as soon as possible.
Posted Jan 21, 2019 - 13:39 EST
This incident affected: Data Protection Portal (Backend services).