Quest Data Protection Service Disruption
Incident Report for Quest Data Protection
Resolved
This incident has been resolved.
Posted Apr 26, 2018 - 13:55 EDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 26, 2018 - 12:50 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 26, 2018 - 12:49 EDT
Investigating
We are currently experiencing a service disruption.
Our engineering team is working to identify the root cause and implement a solution.
Posted Apr 26, 2018 - 12:04 EDT
This incident affected: Rapid Recovery License Portal (Web User Interface).