Data Protection Portal - could not login web page
Incident Report for Quest Data Protection
Resolved
everything works well now
Posted Jun 10, 2019 - 07:06 EDT
Investigating
We are investigating the issue, and will update soon
Posted Jun 10, 2019 - 07:04 EDT
This incident affected: Rapid Recovery License Portal (Web User Interface) and Data Protection Portal (Web User Interface).