Connectivity issues
Incident Report for Quest Data Protection
Resolved
This incident has been resolved.
Posted May 02, 2019 - 17:29 EDT
Investigating
A small percentage of incoming traffic is experiencing intermittent connectivity issues with our system. We are looking into the issue.
Posted May 02, 2019 - 17:20 EDT
This incident affected: Rapid Recovery License Portal (Backend services) and Data Protection Portal (Backend services).