Pages may be slow loading
Incident Report for Quest Data Protection
Resolved
This incident has been resolved.
Posted May 02, 2018 - 10:36 EDT
Update
We are continuing to investigate this issue.
Posted May 02, 2018 - 05:11 EDT
Update
We are continuing to investigate this issue.
Posted May 02, 2018 - 05:11 EDT
Investigating
The Data Protection portal is currently experiencing a higher than normal volume of activity, which may be causing pages to be slow or unresponsive.
We're investigating the cause and will provide an update as soon as possible.
Posted May 02, 2018 - 01:58 EDT
This incident affected: Rapid Recovery License Portal (Web User Interface, Backend services) and Data Protection Portal (Web User Interface, Backend services).